본문 바로가기

PHP/Laravel11

[Laravel] Macbook M1 Pro에서 node 14 버전 설치 valet 설치 후 기존 프로젝트를 돌리기 위해서는 node14버전이 필요 했다. 그래서 npm install을 하면 아래와 같은 오류가 나타났는데 몇일간 이것저것 해보다 결국 M1칩엔 14버전이 설치가 안되는걸 알아냈다. Error: Node Sass does not yet support your current environment: OS X Unsupported architecture (arm64) with Node.js 14.x 아래 블로그 따라해서 설치 완료. 참고 블로그 https://cotak.tistory.com/156 [Node.js] M1에서 nvm 설치하기 NVM(Node Version Manager)이란 Node.js의 버전을 관리해주는 도구이다. 이를 이용해 노드 버전별 설치/삭제를.. 2022. 5. 16.
[Laravel] Valet 에서 laravel 설치 Valet 을 설치 하였으니 laravel 프로젝트를 설치 해본다. 프로젝트를 설치 하고자 하는 디렉토리로 이동하여 명령어를 쳐본다. laravel new dev zsh: command not found: laravel 이런 문구가 나온다. 일단 composer 로 설치 해본다. composer create-project laravel/laravel dev 컴포저가 열일하며 성공적으로 설지 된다. valet은 ~.test로 도메인이 연결되므로 브라우저에 dev.test를 쳐서 접속해본다. 그렇다면 laravel new app 이런식으로 사용하려면 어떻게 해야될까 composer로 laravel/installer를 설치 해야된다. composer global require laravel/installer .. 2022. 5. 11.
[Laravel] Mac 발렛 Valet 설치 MacOs를 위한 개발 환경. https://laravel.kr/docs/8.x/valet 라라벨 8.x - 발렛-Valet 라라벨 한글 메뉴얼 8.x - 발렛-Valet laravel.kr Homebrew 설치 일단 homebrew가 설치 되어 있어야한다. 아래 사이트에서 스크립트를 복사한다. https://brew.sh/index_ko Homebrew The Missing Package Manager for macOS (or Linux). brew.sh /bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)" 터미널에 명령어를 붙여 넣습니다. 맥에 로그인 하는 비밀번호를 입력합니다. Re.. 2022. 5. 7.
홈스테드 오류 모음 > composer install error Composer install Could not delete kylekatarnls/update-helper/src/UpdateHelper → composer install --no-plugins composer downgrad (버전으로 인해 다운그래이드 필요시, 1 아래) → composer self-update --1 ln: failed to create symbolic link 'public/storage/public': Protocol error → 먼저 해당 프로젝트 pulic에 storage폴더가 있는지 확인 → 없으면 mkdir로 public에 storage생성 → rm -rf vendor → composer install → 그래도 안되면 ve.. 2021. 5. 12.