본문 바로가기
PHP/Laravel

[Laravel] Macbook M1 Pro에서 node 14 버전 설치

by 집탱구리 2022. 5. 16.

valet 설치 후 기존 프로젝트를 돌리기 위해서는 node14버전이 필요 했다.

그래서 npm install을 하면 아래와 같은 오류가 나타났는데 몇일간 이것저것 해보다 결국 M1칩엔 14버전이 설치가 안되는걸 알아냈다.

Error: Node Sass does not yet support 
your current environment: OS X Unsupported architecture (arm64) with Node.js 14.x

아래 블로그 따라해서 설치 완료.

 

참고 블로그

https://cotak.tistory.com/156

 

[Node.js] M1에서 nvm 설치하기

NVM(Node Version Manager)이란 Node.js의 버전을 관리해주는 도구이다. 이를 이용해 노드 버전별 설치/삭제를 쉽게 할 수 있으며, 여러 버전의 노드를 설치한 후 선택해서 사용할 수 있다. 0. 미리 설치해

cotak.tistory.com

 

반응형

태그

댓글0